FavoriteLoading
0

configure.ac:3: error: Autoconf version 2.68 or higher is required-建站坊,wordpress建站技术分享

今天在给一个VPS中安装PHP扩展IMAP的时候遇到这个问题,在使用phpize命令的时候报错,所以记录下,主要方便自己下次在遇到好搜索,报错信息如下图。

处理过程:

1.查询当前版本

rpm -qf /usr/bin/autoconf 
autoconf-2.63-5.1.el6.noarch

2.卸载当前版本并安装新版本

rpm -e --nodeps autoconf-2.63
wget http://ftp.gnu.org/gnu/autoconf/autoconf-2.69.tar.gz
tar -zxvf autoconf-2.69.tar.gz
cd autoconf-2.69
mkdir -p /usr/local/autoconf
./configure --prefix=/usr/local/autoconf/
make && make install

3.查看新版本并再次使用phpize没有报错信息了!

/usr/local/autoconf/bin/autoconf –V

提醒: 任何IDC都有倒闭和跑路的可能,出口线路更不可控,月付和备份是您的最佳选择,请保持良好的、有规则的备份习惯.